Как изменить или подменить версию jQuery в Yii1 — РЕШЕНО

Мне понадобилось изменить версию jQuery на сайте под управлением Yii 1 — ой версии, т.к. стоковая была очень древняя и некоторые необходимые скрипты были с ней не совместимы. Немного погуглив я нашел хорошее решение!

В файле конфига (protected/config/main.php) прописываем в ‘components’ => array(…);

 

В результате фреймворк будет подтягивать не стандартный скрипт из фреймворка а тянуть файл http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js .

Надеюсь будет полезно те только мне 🙂

Leave a Comment.